Skip to main content

12 months ago

docker service won't start on worker

I tried following instructions in the lab 
"Hands-on Lab: Configure a Swarm and Scale Services Within Your Cluster" to start a swarm and start a service with 2.

But when I start the service I get the following error trying to start on the worker. I confirmed firewalld is stopped and that I had updated /etc/hosts

"error creating external connectivity network: Failed to Setup IP tables: Unable to enable SKIP DNAT rule: (iptables failed: iptables --wait -t nat -I DOCKER -i docker_gwbridge -j RETURN: iptables: No chain/target/match by that name.

Image of
12 months ago
When you run the 'docker init' command on the master and add the '--advertise-addr', be sure to use the PRIVATE IP of the master server or the key that is generated for the nodes to join will be based on the public IP and the public IP will be what the nodes try to connect to when you copy/paste the join command as listed.

If you are using our cloud servers, you have to use all private addresses or the nodes will be unable to join the master in the swarm over the standard Docker Swarm ports.