Skip to main content
sunnypalsingh

3 years ago

Not able to install openstack version neutron

I am following "
I am following "Packstack on CentOS" tutorial and currently at step [root@centos singh]# packstack --answer-file=/home/singh/answers.txt

Now my installation is stuck at

Applying 192.168.0.10_controller.pp

Testing if puppet apply is finished: 192.168.0.10_controller.pp [ / ]

I have been waiting for 2 hours now...

Can you suggest how to resolve this?"

Image of sunnypalsingh
sunnypalsingh
3 years ago
I notice in /var/log/messages that connection towards port 5672 is failing

May 20 21:38:17 centos cinder-scheduler: 2017-05-20 21:38:17.605 880 ERROR oslo.messaging._drivers.impl_rabbit [req-8eee6ec8-5d05-4cf5-ba77-53739332fa6d - - - - -] [00a39e26-c5cd-480d-9975-a7c19054ae7a] AMQP server on 192.168.0.10:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 32 seconds. Client port: None


I renabled firewalld and allowed tcp port 5672 but that also did not help. Tried starting rabbitmq manually, did not work.

Can anyone help in this?


Image of jgriano
jgriano
3 years ago

In this course, it is an all-in-one deployment. Could you do a telnet to the 5672 port in localhost or with the 192.168.0.10 IP? 

Image of trilliams
trilliams
3 years ago
Hi @sunnypalsingh ,

Before launching Packstack you will need to completely disable both firewalld & networkmanager, as OpenStack Packstack has its own version of iptables that it sets & manages rules from. As for RabbitMQ, are you saying that it isn't starting, or after manually starting it still doesn't connect?
Image of sunnypalsingh
sunnypalsingh
3 years ago
Hi Treva,

I did disabled both firewalld and networkmanager. Sharing steps which I did after installing centOS. Kindly let me know what is missed or doing wrong.

[root@centos ~]# yum -y update

[root@centos ~]# yum -y install centos-release-qemu-ev

[root@centos ~]# yum -y remove mariadb-libs

[root@centos ~]# visudo

## Same thing without a password

%wheel ALL=(ALL) NOPASSWD: ALL

[root@centos ~]# vi /etc/selinux/config

SELINUX=disabled

[root@centos ~]# systemctl disable NetworkManager firewalld

[root@centos ~]# reboot

[singh@centos ~]$ yum search openstack

[root@centos ~]# yum -y install centos-release-openstack-newton.noarch

[root@centos ~]# yum -y install openstack-packstack

[root@centos ~]# packstack --gen-answer-file=/home/singh/answers.txt

[root@centos singh]#vi answers.txt

CONFIG_DEFAULT_PASSWORD=openstack

CONFIG_HEAT_INSTALL=y

Also changed admin and demo users passwords to openstack and demo.

[root@centos singh]# packstack --answer-file=/home/singh/answers.txt



Image of sunnypalsingh
sunnypalsingh
3 years ago
I looked into /var/log/messages and there was continous error where it says connection towards 192.168.0.10:5672 is refused. So, I tried starting RabbitMQ manually but it did not work.
Image of sunnypalsingh
sunnypalsingh
3 years ago
RabbitMQ did not start I meant

Image of trilliams
trilliams
3 years ago
Ok so that's the issue. You'll have to figure out why rabbitmq isn't starting. You should be able to at least get a hint on why it isn't starting from systemctl status rabbitmq.
Image of sunnypalsingh
sunnypalsingh
3 years ago
Found the issue. Problem was /etc/hosts file. For some reason it did not have my new hostname(centos). After adding that and re-running installation all worked fine. Thanks everyone!!