RHN error while using yum

Hi Guys,
Ive had issues trying to install packages on different computers than my own. Basically I get a RHN suscribtion error and when I do yum repolist it shows 0 packages.
I have verified the syntax and know that it is spotless.
Is there any way to install things without an RHN suscription ?
  • post-author-pic
    Anthony J
    02-02-2015

    If your using Redhat Enterprise 7 that is outside the trial and does not have a license then no there is not. I would suggest either licensing redhat or using Centos 7 instead.

  • post-author-pic
    Arrey A
    02-02-2015

    You can build your own repository using the rhel iso . Don't license from red hat if you are just practicing. As Anthony mentioned, you can also use centos. If you are focusing on red hat, learn how to build a local yum repository. Youtube it. If you have any issues, I will be glad to help.

    Thanks

  • post-author-pic
    Paloma V
    02-03-2015

    Thks for the answers.
    I know how to create a repo. The issue came in a testing enviroment where my machine didnt have a rhn suscription. I saw some repos created and I had the info to create a new one. I created a new one but it was still complaining about not being suscribed to RHN. I tried to disable the repos I could see in the /etc/yum.repos.d but still got the same error.
    Today I read that I should
    #yum clean all
    in order to update the cache but im still feeling skeptical.

  • post-author-pic
    Paloma V
    02-03-2015

    btw, im using rhel6

  • post-author-pic
    Terrence C
    02-03-2015

    if you have to use RHEL and cannot pay the subscription for official updates, you CAN add the RPMFusion and EPEL repos which still allows installation and most security updates. However, that is not an officially supported method and your mileage may vary.

    Good luck!

  • post-author-pic
    Arrey A
    02-03-2015

    You can use :

    # yum clean all

    that will not cause any harm. To better assist you, can you post the entire output when you do :

    # yum repolist

    Thanks

  • post-author-pic
    Fernando F
    02-03-2015

    If your message is something like this:

    "This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register"

    You can just disable the subscription manager plugin.

    Edit the subscription-manager.conf file and change enable=1 to enable=0
    # nano or vi /etc/yum/pluginconf.d/subscription-manager.conf

    And change this:
    [main]
    enabled=0

    to this:
    [main]
    enabled=1

    You can test with yum repolist

    Regards,

    Fernando

  • post-author-pic
    Fernando F
    02-03-2015

    Sorry Paloma, I made a mistake.

    You need change this:
    [main]
    enabled=1

    to this:
    [main]
    enabled=0

    Sorry

    Fernando

  • post-author-pic
    Paloma V
    02-03-2015

    Awesome. Thks for the ideas
    I will try all

  • post-author-pic
    Arrey A
    02-04-2015

    Thanks Fernando. Paloma , please let us how it went. We will like to get this working for you.

    Also, in /etc/yum.repos.d , there is this file in there "rhel-source.repo" . This file belongs to red hat . Make sure all the :
    " enabled" keyword are turned off (0)

    This is the entry :

    [rhel-source]
    name=Red Hat Enterprise Linux $releasever - $basearch - Source
    baseurl=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/$releasever/en/os/SRPMS/
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

    [rhel-source-beta]
    name=Red Hat Enterprise Linux $releasever Beta - $basearch - Source
    baseurl=ftp://ftp.redhat.com/pub/redhat/linux/beta/$releasever/en/os/SRPMS/
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta,file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

  • post-author-pic
    Paloma V
    03-03-2015

    Hi Guys,
    Just to confirm that the suggestions you gave me worked during my exam.
    I disabled all the repos i found on /etc/yum.repos.d and enabled the one I needed.
    After that yum clean all and yum update.

Looking For Team Training?

Learn More